Is xTuple compatible with Ubuntu 16?

The short answer is, yes. However, to run xTuple ERP on Ubuntu 16 you must install some backwards-compatibility packages:

sudo add-apt-repository -y "deb http://ftp.debian.org/debian trusty-backports universe restricted main"
sudo add-apt-repository -y "deb http://us.archive.ubuntu.com/ubuntu trusty restricted multiverse main universe"
sudo add-apt-repository -y "deb http://us.archive.ubuntu.com/ubuntu trusty-updates restricted universe main multiverse"
sudo add-apt-repository -y "deb http://us.archive.ubuntu.com/ubuntu trusty-backports main restricted universe multiverse"
sudo add-apt-repository -y "deb http://security.ubuntu.com/ubuntu trusty-security main multiverse universe restricted"
sudo apt-get update
sudo apt-get install libwebp5 libgstreamer0.10-0 libgstreamer-plugins-base0.10-dev libgstreamer0.10-dev libicu52